Forums / Allocatus Forum (English) / Allocatus Server does not have the required permissions to access the Exchange mailbox of the user

Allocatus Server does not have the required permissions to access the Exchange mailbox of the user

2 posts, 1 answered
  1. user
    user avatar
    213 posts
    Registered:
    09 Aug 2015
    Answered
    11 Aug 2015
    Link to this post

    In the Event Log Allocatus Log and the latest log file in the folder LOG in the ProgramDir of Allocatus Server (e.g. C:\Program Files (x86)\Allocatus\Server) I see the following message: 

    Allocatus Server does not have the required permissions to access the Exchange mailbox of the user Domain\User.

    For that reason Allocatus Server sends an e-mail to the user (Authorization mail). The user needs to go to his/her Outlook inbox, click on the link 'Set Permissions' and enter his/her password to grant Allocatus Server the required permissions.

    Last modified on 18 May 2016 19:05 by aniko.erlinger
  2. admin
    admin avatar
    198 posts
    Registered:
    09 Aug 2015
    11 Aug 2015 in reply to user
    Link to this post

    Allocatus Server is using a Windows user account to access the Exchange Server farm (Exchange access account). This account is configured in the Allocatus Server Configuration (Connections/Exchange Server). By default you use the option Use a specific user account and specify the account in the format Domain\User. This account must be an active Windows account with an Exchange mailbox.

    This account is used to access the calendar and task folder in the Exchange mailbox of any user that is listed in the Allocatus Server Configuration (Settings/User Settings) with Groupware Exchange. It needs to have the following permissions:

    1. Root of the mailbox: Reviewer
    2. Calendar and task folder: Editor
    3. Delegate Access with option Delegate can see my private items (Optional, if you want to link private appointments or events)

    If this account does not have the required permissions Allocatus Server sends out an e-mail to the owner of the mailbox through the Smtp Server (Settings/Mail settings). Once the user has set the required permission the sync will work and the message will disappear from the logs. If this fails the user can manually set the permission in Outlook: Right click folder, select Permissions, add the account and change the Permission Level. To grant Delegate Access go to select File/Account Settings/Delegate Access, add the account set the permission levels for each folder and check Delegate can see my private items.

    Note: In case of missing permissions: Exchange Server answers with the following error message: The specified folder could not be found in the store, see also this forum thread: Failed to read an element in the mailbox of the user.

    You can increase the tag LogLevel to 1 or higher in the config.xml to get the detailed technical information

    Last modified on 20 Jan 2017 11:01 by maximilian.wagner
2 posts, 1 answered

Search Forum Posts