Forums / Allocatus Forum (English) / Resource with Windows account Domain\UserName not found in Project Server

Resource with Windows account Domain\UserName not found in Project Server

2 posts, 0 answered
  1. user
    user avatar
    213 posts
    Registered:
    09 Aug 2015
    11 Aug 2015
    Link to this post

    I receive the exception:

    Resource with Windows account i:0#.w|Domain\UserName not found in Project Server.

    Last modified on 18 May 2016 20:05 by aniko.erlinger
  2. admin
    admin avatar
    198 posts
    Registered:
    09 Aug 2015
    11 Aug 2015 in reply to user
    Link to this post

    Hi,

    when Allocatus Server checks the availability of Project Server or if it syncs tasks for a particular users it tries to identify the user by his/her Windows account. If you are using classic-mode authentication with Windows all user logon accounts must have the notation Domain\UserName. If your are using claims-based authentication with Windows all user logon account need to have the notation i:0#.w|Domain\UserName.

    You can change the user logon account for Project Server users if you go to Project Web App/Server Settings/Manage Users. You only need to update the user accounts for users that are synchronized by Allocatus and for the service account used by Allocatus Server to access Project Server.

    If you are using-claims based authentication you need to have Allocatus Server 3.7.4 or higher and you need to set the tag ClaimsBasedAuthenticationEnabled in config.xml to true. If the tag does not exist, Open the config.xml file. Insert the following tag:
    <ClaimsBasedAuthenticationEnabled>true</ClaimsBasedAuthenticationEnabled>
    after the tag
    <ProjectServerComponent>

    The config.xml is located in Allocatus ProgramDir (e.g. at C:\Program Files(x86)\Allocatus\Server\bin). Please note that you cannot use forms-based authentication (fba). It's possible to run FBA on a separate web application, how ever the web application running the PWA Url configured in Allocatus Server settings needs to be set to Windows authentication only.

    For Project Server 2013:

    Allocatus requires the  Project Server Permission Mode. Ensure that it's enabled. For information how to do, go to the thread How to set Project Server permission mode in Project Server 2013 on-premise.

    After you have enabled the Project Server Permission Mode, make sure the tag ClaimsBasedAuthenticationEnabled is set to true and add Allocatus service account to the Project Server Administrators group in Project Server 2013 (See Allocatus Admin Guide Configure Allocatus/Configure Project Server 2013 Connection).

    Allocatus Admin

    Last modified on 18 May 2016 20:05 by aniko.erlinger
2 posts, 0 answered

Search Forum Posts